artem
16.01.2013
35395

Настройка коммутатора Cisco и Voice VLAN (на примере Cisco 2960 и Cisco SPA-502)

Имея сетевую инфраструктуру на Cisco Catalyst, при внедрении телефонии целесообразно выделить в отдельный VLAN всю телефонию. Кроме того, нередко, имея один сетевой интерфейс на сервере телефонии Asterisk, требуется подключить к нему несколько сетей: локальную сеть, Интернет ( прямой доступ), кабель с телефонией от провайдера телефонии, возможно и другие сети. Для настройки такой схемы нам понадобится технология Cisco VLAN Trunk.

Описание сети

Настраиваем коммутатор Cisco (на примере Cisco 2960)

Настраиваем порты для пользователей

Настраиваем порт для подключения маршрутизатора

Настраиваем порт для подключения прямого доступа в Интернет

Настраиваем порт для подключения оператора телефонии

Настраиваем транковый порт для подключения сервера Asterisk

Настройка VLAN-интерфейсов на сервере Linux

Cisco Asterisk

Описание сети:

Общая схема нашей сети будет выглядеть следующим образом:

Cisco VLAN Trunk Configuration

Порты 1-20 будут настраиваться для подключения рабочих мест пользователей: IP-телефон Cisco и компьютер.

В 21-й порт будет подключен маршрутизатор, через который компьютеры имеют доступ в Интернет.

В 22-й порт подключается кабель с Интернетом от провайдера, для обеспечения прямого доступа в Интернет с сервера Asterisk (требуется для внешних SIP-абонентов).

В 23-й порт подключается кабель с Телефонией от оператора связи. Часто оператором связи и провайдером Интернета может быть одна компания, но это — не обязательно. Предлагаемая конфигурация описывает оба этих случая.

В 24-й порт подключается сам сервер телефонии Asterisk.

Настраиваем коммутатор Cisco (на примере Cisco 2960).

Подключаемся к коммутатору в консольном или ssh-режиме. Далее будут идти примеры конфигурации, специалисту ранее работавшим с оборудованием Cisco станет понятно, каким образом реализовать предлагаемую конфигурацию.

Настраиваем порты для пользователей:

Для того чтобы одним разом настроить диапазон, вводим команду:

interface range FastEthernet0/1-19

Далее задаем параметры:

switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast

Здесь указано, что для компьютеров пользователей выделяется VLAN 10 (тип — access), а для тефонии — VLAN 20 (тип voice). Switchport mode access означает, что порт предназначен для end-user-ов.

Настраиваем порт для подключения маршрутизатора:

Настройка аналогична предыдущей, но мы не задаем Voice-VLAN:

interface FastEthernet0/21
switchport access vlan 10
switchport mode access
spanning-tree portfast

Настраиваем порт для подключения прямого доступа в Интернет:

interface FastEthernet0/22
switchport access vlan 30
switchport mode access
spanning-tree portfast

Настраиваем порт для подключения оператора телефонии:

interface FastEthernet0/23
switchport access vlan 100
switchport mode access
spanning-tree portfast

Настраиваем транковый порт для подключения сервера Asterisk:

Данный порт в отличии от предыдущих будет являться транковым, т.е. будет в тегированном виде пропускать трафик из разных VLAN-подсетей.

interface FastEthernet0/24
switchport trunk allowed vlan 10,20,30,100
switchport mode trunk

Мы указали тип порта и разрешенные для пропуска VLAN-ы.

В целом, настройка VLAN-параметров и интерфейсов коммутатора выполнена.

Опционально рекомендуется настроить на коммутаторе DHCP-сервер, SSH-доступ, отключение лишних служб.

Настройка VLAN-интерфейсов на сервере Linux.

Данный пример рассматривается для сервера Linux CentOS.

В первую очередь нужно создать файлы ifcfg-eth0.XXX, где XXX — номера всех VLAN-ов, которые мы будем подключать к серверу. Эти файлы должны лежать в директории /etc/sysconfig/network-scripts/.

В самих файлах будет такое содержимое (при наличии DHCP в той сети, в VLAN которой мы подключаемся):

DEVICE=eth0.10
VLAN=yes
BOOTPROTO=dhcp
ONBOOT=yes

Или таким, при необходимости в явном виде указать IP:

DEVICE=eth0.10
VLAN=yes
BOOTPROTO=none
ONBOOT=yes
HOTPLUG=no
IPADDR=192.168.10.250
NETMASK=255.255.255.0
TYPE=Ethernet

Обратите внимание, где в этом файле указывается к какому сетевому интерфейсу (DEVICE=eth0.10) и к какому VLAN он относится (DEVICE=eth0.10).

Также должен быть основной файл ifcfg-eth0, его содержимое может быть таким (поменяйте MAC-адрес):


DEVICE=eth0
BOOTPROTO=none
HWADDR=90:FB:A6:2F:A0:75
ONBOOT=yes

Таким образом в директории /etc/sysconfig/network-scripts/ у Вас будут расположены следующие файлы, каждый из которых будут прописывать собственные сетевые настройки:

ifcfg-eth0
ifcfg-eth0.10
ifcfg-eth0.20
ifcfg-eth0.30
ifcfg-eth0.100

Для перезапуска интерфейса и применения сетевых настроек запускаем команду service network restart.

Далее, проверяем доступность всех интерфейсов командой ping. Всё должно работать!

Обеспечив доступ к Вашему серверу Asterisk из разных сетей, обязательно ограничьте его и фильтруйте с помощью IPTables!

Подписаться
Уведомление о
guest
0 Комментарий
Inline Feedbacks
View all comments

Остались вопросы?

Я - Виталий Шелест, менеджер компании Voxlink. Хотите уточнить детали или готовы оставить заявку? Укажите номер телефона, я перезвоню в течение 3-х секунд.

VoIP оборудование

ближайшие курсы

ближайшие Вебинары

ONLINE

10 доводов в пользу Asterisk

Распространяется бесплатно.

Asterisk – программное обеспечение с открытым исходным кодом, распространяется по лицензии GPL. Следовательно, установив один раз Asterisk вам не придется дополнительно платить за новых абонентов, подключение новых транков, расширение функционала и прочие лицензии. Это приближает стоимость владения станцией к нулю.

Безопасен в использовании.

Любое программное обеспечение может стать объектом интереса злоумышленников, в том числе телефонная станция. Однако, сам Asterisk, а также операционная система, на которой он работает, дают множество инструментов защиты от любых атак. При грамотной настройке безопасности у злоумышленников нет никаких шансов попасть на станцию.

Надежен в эксплуатации.

Время работы серверов некоторых наших клиентов исчисляется годами. Это значит, что Asterisk работает несколько лет, ему не требуются никакие перезагрузки или принудительные отключения. А еще это говорит о том, что в районе отличная ситуация с электроэнергией, но это уже не заслуга Asterisk.

Гибкий в настройке.

Зачастую возможности Asterisk ограничивает только фантазия пользователя. Ни один конструктор шаблонов не сравнится с Asterisk по гибкости настройки. Это позволяет решать с помощью Asterisk любые бизнес задачи, даже те, в которых выбор в его пользу не кажется изначально очевидным.

Имеет огромный функционал.

Во многом именно Asterisk показал какой должна быть современная телефонная станция. За многие годы развития функциональность Asterisk расширилась, а все основные возможности по-прежнему доступны бесплатно сразу после установки.

Интегрируется с любыми системами.

То, что Asterisk не умеет сам, он позволяет реализовать за счет интеграции. Это могут быть интеграции с коммерческими телефонными станциями, CRM, ERP системами, биллингом, сервисами колл-трекинга, колл-бэка и модулями статистики и аналитики.

Позволяет телефонизировать офис за считанные часы.

В нашей практике были проекты, реализованные за один рабочий день. Это значит, что утром к нам обращался клиент, а уже через несколько часов он пользовался новой IP-АТС. Безусловно, такая скорость редкость, ведь АТС – инструмент зарабатывания денег для многих компаний и спешка во внедрении не уместна. Но в случае острой необходимости Asterisk готов к быстрому старту.

Отличная масштабируемость.

Очень утомительно постоянно возвращаться к одному и тому же вопросу. Такое часто бывает в случае некачественного исполнения работ или выбора заведомо неподходящего бизнес-решения. С Asterisk точно не будет такой проблемы! Телефонная станция, построенная на Asterisk может быть масштабируема до немыслимых размеров. Главное – правильно подобрать оборудование.

Повышает управляемость бизнеса.

Asterisk дает не просто набор полезных функций, он повышает управляемость организации, качества и комфортности управления, а также увеличивает прозрачность бизнеса для руководства. Достичь этого можно, например, за счет автоматизации отчетов, подключения бота в Telegram, санкционированного доступа к станции из любой точки мира.

Снижает расходы на связь.

Связь между внутренними абонентами IP-АТС бесплатна всегда, независимо от их географического расположения. Также к Asterisk можно подключить любых операторов телефонии, в том числе GSM сим-карты и настроить маршрутизацию вызовов по наиболее выгодному тарифу. Всё это позволяет экономить с первых минут пользования станцией.