artem
12.04.2013
27885

Настройка GSM-шлюза AddPac AP-GS1001 для работы с Asterisk

   В этой статье речь пойдет о подключении GSM-шлюза AP-GS1001 к Asterisk. Все описанные настройки выполняются из консоли устройства. FXS-порт и функции роутера использованы не будут.
IP-адрес хоста Asterisk — 192.168.5.100
IP-адрес AddPac AP-GS1001 — 192.168.5.99

1. Подключение к шлюзу
2. Меняем пароль.
3. Новый IP на LAN1
4. Ограничение доступа к шлюзу
5. Настройка GSM-порта
6. VOIP настройки
7. Настройка Asterisk
8. Листинг конфига AddPac AP-GS1001

[Image]

Подключение к шлюзу


IP-адрес GSM-шлюза по умолчанию — 192.168.10.1, логин и пароль по умолчанию — root router. Подключаемся к шлюзу по telnet, заходим в режим настройки.

enable
configure terminal

Меняем пароль.


username admin password secret administrator
no username root

Новый IP на LAN1


Настраиваем новый IP-адрес на интерфейсе LAN1 (после чего, естественно, нужно будет переподключиться), LAN0 отключаем за ненадобностью.

interface FastEthernet0/1
ip address 192.168.5.99 255.255.255.0
exit

interface FastEthernet0/0
no ip address
shutdown
exit

Ограничение доступа к шлюзу


Ограничиваем доступ к шлюзу (в данном случае подключения по telnet да и весь IP-трафик будет приниматься только с хоста Asterisk)

access-list 50 permit host 192.168.5.100
access-list 50 deny any
line vty
access-class 50
exit

access-list 100 permit ip host 192.168.5.100 any
access-list 100 deny ip any any

interface FastEthernet0/1
ip access-group 100 in
exit

Настройка GSM-порта


Настраиваем параметры GSM-порта (порт 0/0, входящие вызовы будут передаваться в Asterisk на номер 89991112222) и создадим dial-peer для звонков через него, FXS-порт отключаем за ненадобностью

voice-port 0/0
connection plar 89991112222
caller-id enable
exit

dial-peer voice 1000 pots
destination-pattern. T
port 0/0
call-waiting

user-name addpac
user-password sip-secret
exit

voice-port 0/1
shutdown
exit

ПРИМЕЧАНИЕ: В настройках dial-peer указываются имя и пароль, которые будут проверяться при SIP-аутентификации при звонках через этот dial-peer

VOIP настройки


Настраиваем параметры VoIP (используемые кодеки, параметры передачи DTMF и факсов, параметры подключения к Asterisk, dial-peer для VoIP-вызовов)

voip-interface ip FastEthernet0/1

voice service voip

protocol sip

dtmf-relay rfc-2833

fax protocol t38 redundancy 0

fax rate 9600
exit

voice class codec 0
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729
exit

sip-ua
sip-username addpac
sip-password sip-secret
sip-server 192.168.5.100
exit

dial-peer voice 2000 voip
destination-pattern 89991112222
session target ip 192.168.5.100 5060
session protocol sip

voice-class codec 0
no vad

dtmf-relay rtp-2833
description asterisk
exit

ПРИМЕЧАНИЕ: Логин и пароль, указанные в настройках sip-ua будут использоваться в SIP-аутентификации при звонках на Asterisk

ПРИМЕЧАНИЕ: В настройках dial-peer в destination-pattern должен быть указан номер, указанный ранее в настройках GSM-порта в пункте connection plar (Входящие по GSM вызовы будут передаваться в Asterisk на этот номер).Сохраняем конфигурацию
copy running-config startup-config

Применение настроек в web-интерфейсе шлюза собьет многие из выполненных настроек, поэтому лучше его отключить
no http server
ПРИМЕЧАНИЕ: включить web-интерфейс после отключения мне не удалось. Сброс на заводские настройки, скорее всего, вернет web-интерфейс

Настройка Asterisk


Настраиваем SIP-пир, входящий маршрут, исходящий маршрут.

/etc/asterisk/sip.conf
[addpac]
host=192.168.5.99
type=peer
defaultuser=addpac
secret=sip-secret
context=from-trunk
nat=no
qualify=yes
disallow=all
allow=alaw
allow=ulaw
allow=g729
deny=0.0.0.0/0.0.0.0
permit=192.168.5.99/255.255.255.255

/etc/asterisk/extensions.conf
[from-trunk]
exten => 89991112222,1,Dial (SIP/100,30)
same => n,Hangup ()

[from-internal]
exten => _89XXXXXXXXX,1,Dial (SIP/addpac/${EXTEN})
same => n,Hangup ()

ПРИМЕЧАНИЕ: Если шлюз отбивает вызовы сообщением 603 Declined, следует проверить состояние GSM-модуля командой
show gsm module status

Если счетчик UNREG растет, значит SIM-карта пытается регистрироваться у провайдера, скорее всего из-за слабого сигнала.

Листинг конфига AddPac AP-GS1001


!
version 8.51.002
!
hostname GS1001
!
username admin password NMzrZGuWHzs4OUKJ administrator
!
!
interface Loopback0
 ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/10
 no ip address
 shutdown
 speed auto
 no qos-control
!
interface FastEthernet0/1
 ip address 192.168.5.100 255.255.255.0
 ip access-group 100 in
 speed auto
 no qos-control
!
ip route 0.0.0.0 0.0.0.0 192.168.5.1
!
access-list 50 permit host 192.168.5.100
access-list 50 deny any
access-list 100 permit ip host 192.168.5.100 any
access-list 100 deny ip any any
!
!
!
logging command
logging event 4-warning
logging on
!
!
!
!
! VoIP configuration.
!
!        
! Voice service voip configuration.
!
voice service voip
 protocol sip
 dtmf-relay rfc-2833
 fax protocol t38 redundancy 0
 fax rate 9600
 h323 call start fast
 h323 call tunnel enable
 no call-barring unconfigured-ip-address
 no voip-inbound-call-barring enable
!
!
! Voice port configuration.
!
! GSM
voice-port 0/0
 connection plar 89991112222
 ring detect-timeout 70
 caller-id enable
 caller-id type etsi
 caller-id name disable
!
!
! FXS
voice-port 0/1
 caller-id enable
 shutdown
!
!
!
!
! service port group configuration.
!
!
!
! Pots peer configuration.
!
dial-peer voice 1000 pots
 destination-pattern. T
 port 0/0
 call-waiting
 user-name addpac
 user-password sip-secret
!        
!
!
! Voip peer configuration.
!
dial-peer voice 2000 voip
 destination-pattern 89991112222
 session target ip 192.168.5.100 5060
 session protocol sip
 voice-class codec 0
 no vad
 dtmf-relay rtp-2833
 description asterisk
!
!
!
!
!
!
gatekeeper
!
!
! Gateway configuration.
!
gateway
 h323-id voip.192.168.5.99
 no ignore-msg-from-other-gk
!
!
! Codec classes configuration.
!
voice class codec 0
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729
!
!
!
! SIP UA configuration.
!
sip-ua
 sip-username addpac
 sip-password sip-secret
 sip-server 192.168.5.100
 session-refresh update
!        
!
! Tones
!
!
!
voip-interface ip FastEthernet0/1
!
line console
!
line vty
 access-class 50
!
gsm dev-restart-by-unreg 300
!
gsm 0/0
 sms-language utf8
!
end

Подписаться
Уведомление о
guest
0 Комментарий
Inline Feedbacks
View all comments

Остались вопросы?

Я - Виталий Шелест, менеджер компании Voxlink. Хотите уточнить детали или готовы оставить заявку? Укажите номер телефона, я перезвоню в течение 3-х секунд.

VoIP оборудование

ближайшие курсы

ближайшие Вебинары

ONLINE

10 доводов в пользу Asterisk

Распространяется бесплатно.

Asterisk – программное обеспечение с открытым исходным кодом, распространяется по лицензии GPL. Следовательно, установив один раз Asterisk вам не придется дополнительно платить за новых абонентов, подключение новых транков, расширение функционала и прочие лицензии. Это приближает стоимость владения станцией к нулю.

Безопасен в использовании.

Любое программное обеспечение может стать объектом интереса злоумышленников, в том числе телефонная станция. Однако, сам Asterisk, а также операционная система, на которой он работает, дают множество инструментов защиты от любых атак. При грамотной настройке безопасности у злоумышленников нет никаких шансов попасть на станцию.

Надежен в эксплуатации.

Время работы серверов некоторых наших клиентов исчисляется годами. Это значит, что Asterisk работает несколько лет, ему не требуются никакие перезагрузки или принудительные отключения. А еще это говорит о том, что в районе отличная ситуация с электроэнергией, но это уже не заслуга Asterisk.

Гибкий в настройке.

Зачастую возможности Asterisk ограничивает только фантазия пользователя. Ни один конструктор шаблонов не сравнится с Asterisk по гибкости настройки. Это позволяет решать с помощью Asterisk любые бизнес задачи, даже те, в которых выбор в его пользу не кажется изначально очевидным.

Имеет огромный функционал.

Во многом именно Asterisk показал какой должна быть современная телефонная станция. За многие годы развития функциональность Asterisk расширилась, а все основные возможности по-прежнему доступны бесплатно сразу после установки.

Интегрируется с любыми системами.

То, что Asterisk не умеет сам, он позволяет реализовать за счет интеграции. Это могут быть интеграции с коммерческими телефонными станциями, CRM, ERP системами, биллингом, сервисами колл-трекинга, колл-бэка и модулями статистики и аналитики.

Позволяет телефонизировать офис за считанные часы.

В нашей практике были проекты, реализованные за один рабочий день. Это значит, что утром к нам обращался клиент, а уже через несколько часов он пользовался новой IP-АТС. Безусловно, такая скорость редкость, ведь АТС – инструмент зарабатывания денег для многих компаний и спешка во внедрении не уместна. Но в случае острой необходимости Asterisk готов к быстрому старту.

Отличная масштабируемость.

Очень утомительно постоянно возвращаться к одному и тому же вопросу. Такое часто бывает в случае некачественного исполнения работ или выбора заведомо неподходящего бизнес-решения. С Asterisk точно не будет такой проблемы! Телефонная станция, построенная на Asterisk может быть масштабируема до немыслимых размеров. Главное – правильно подобрать оборудование.

Повышает управляемость бизнеса.

Asterisk дает не просто набор полезных функций, он повышает управляемость организации, качества и комфортности управления, а также увеличивает прозрачность бизнеса для руководства. Достичь этого можно, например, за счет автоматизации отчетов, подключения бота в Telegram, санкционированного доступа к станции из любой точки мира.

Снижает расходы на связь.

Связь между внутренними абонентами IP-АТС бесплатна всегда, независимо от их географического расположения. Также к Asterisk можно подключить любых операторов телефонии, в том числе GSM сим-карты и настроить маршрутизацию вызовов по наиболее выгодному тарифу. Всё это позволяет экономить с первых минут пользования станцией.