Курсы по использованию Asterisk

IP-телефония — технология будущего. Обучитесь работе с IP-АТС Asterisk для того чтобы внедрить и профессионально использовать при решении коммуникационных задач.

Работайте с Asterisk профессионально!

Многоуровневая защита IP-АТС Asterisk

Телефонные станции очень часто становятся объектами хакерских атак. Узнайте, каким образом необходимо строить многоуровневую защиту для Вашей IP-АТС.

Не оставьте хакерам шансов. Защитите свой Asterisk от атак.

Используйте Веб-Интерфейс для удобства настройки

Панель управление FreePBX позволяет легко и удобно управлять всей системой. Научитесь эффективно использовать FreePBX для решения своих задач.

Управление станцией и статистика в окне браузера.

Научитесь работать с Asterisk из консоли

Для понимания работы с Asterisk необходимо уметь настраивать его вручную с конфигурационными файлами и командной строкой CLI Asterisk.

Научитесь «тонкой» настройке Asterisk

Цель курсов - максимум практики.

Обучение нацелено на практическую работу с IP-оборудованием: платы потоков E1, VoIP-телефонные аппараты, голосовые шлюзы FXS и прочее.

Обучение на реальном оборудовании — залог успеха.

Настройка шлюза Cisco 1760 для связки Asterisk с аппаратной АТС

База знаний Настройка VoIP-оборудования
Шлюз Cisco 1760 VoIP E1 Bundle - возможно самый дешёвый способ перевести один поток E1 в SIP на момент написания статьи. В комплект Cisco 1760 VoIP E1 Bundle входят все необходимые модули для подключения потока E1, ниже будет описана настройка этого шлюза для связки Asterisk с аппаратной АТС.

Настройка параметров подключения к сети на шлюзе Cisco 1760



Предварительные данные:
IP-адрес сервера Asterisk - 192.168.99.100/24
IP-адрес для шлюза Cisco 1760 - 192.168.99.120/24
Шлюз по умолчанию - 192.168.99.1 Приступаем к настройке.

Если шлюз б/у, скорее всего на нём есть старый конфиг, подключитесь к шлюзу с помощью консольного кабеля, удалите startup-config и перезагрузите шлюз.

enable
erase startup-config
reload

После загрузки шлюз будет периодически пытаться скачать конфиги по TFTP, чтобы шлюз перестал это делать, нужно выполнить настройку «no service config» (заодно сразу выключите domain-lookup и задайте имя хоста):

enable
conf t
no service config
no ip domain-lookup
hostname E1GW

Настраиваем IP-адрес:

interface FastEthernet 0/0
ip address 192.168.99.120 255.255.255.0
exit

Настраиваем шлюз по умолчанию (если Asterisk и Cisco 1760 находятся в одной подсети, основной шлюз не обязателен для работы SIP):

ip route 0.0.0.0 0.0.0.0 192.168.99.1

Настраиваем доступ к шлюзу по SSH и создаём пользователя cisco_user для подключения по SSH:

aaa new-model
aaa session-id common
crypto key generate rsa general-keys modulus 1024
ip ssh time-out 90
ip ssh authentication-retries 2
ip ssh version 2
username cisco_user privilege 15 secret 0 your_password_here

Разрешим удалённую консоль только по SSH и выполним ещё пару настроек безопасности:

liny vty 0 4
exec-timeout 20 0
privilege level 15
logging synchronous
transport input ssh
exit

Теперь можно подключиться к шлюзу по SSH и продолжить настройку.

Настройка параметров E1 и VoIP на шлюзе Cisco 1760


Предварительные данные:
номера на стороне аппаратной АТС - 2XX
номера на стороне Asterisk - 1XX
сигналирование на стороне аппаратной АТС - EuroISDN CPE
аппаратная АТС будет использовать шлюз как источник синхронизации
фрейминг с CRC4
По умолчанию шлюз Cisco 1760 использует E1 как источник синхронизации, нужно поменять источник синхронизации на встроенный таймер, т.к. шлюз Cisco 1760 сам будет источником синхронизации в данной схеме.

no tdm clock E1 0/0
tdm clock E1 0/0 both import onboard internal

Устанавливаем сигналирование EuroISDN:

isdn switch-type primary-net5

Вносим настройки интерфейса E1:

controller e1 0/0
framing crc4
linecode hdb3
pri-group timeslots 1-31
exit

После этого в системе появится интерфейс Serial0/0:15 с готовым набором настроек, к его настрокам нужно добавить включение сигналирования EuroISDN NET на стороне шлюза (по умолчанию - CPE)

interface Serial0/0:15
isdn protocol-emulate network
exit

Создаём группу кодеков и dial-peer для вызовов на Asterisk по SIP:

voice class codec 1
codec preference 1 g711alaw
exit
dial-peer voice 10 voip
destination-pattern 1..
voice-class codec 1
session protocol sipv2
session target ipv4:192.168.99.100:5060
session transport udp
dtmf-relay rtp-nte
no vad
exit

Настраиваем юзерагента SIP для приёма входящих вызовов по SIP:

sip-ua
sip-server ipv4:192.168.99.100:5060
exit

Если планируется передавать факсы, внесите настройки передачи факсов:

voice service voip
fax protocol pass-through g711alaw
exit

Для передачи факсов по T.38 используйте вместо этого:

voice service voip
fax protocol t38
exit

Создаём dial-peer для вызовов через E1 на аппаратную АТС:

dial-peer voice 20 pots
destination-pattern 2..
direct-inward-dial
port 0/0:15
forward-digits all
exit

Настройка завершена, для сохранения настроек, выйдите из режима настройки и выполните команду:

copy running-config startup-config

Настройка на стороне Asterisk


На стороне Asterisk нужно создать обычное SIP-подключение без регистрации:

[cisco_e1gw]
host=192.168.99.120
type=friend
nat=no
qualify=yes
canreinvite=no
disallow=all
allow=alaw
insecure=invite,port
context=from-other-pbx
from-other-pbx - ограниченный контекст, из которого можно звонить только на внутренние номера.

Отладка


Для начала проверьте, установлено ли соединение по E1. Выполните команду:

show controllers e1

Пример вывода:

E1 0/0 is up.
Applique type is Channelized E1 - balanced
No alarms detected.
alarm-trigger is not set
Version info Firmware: 20090113, FPGA: 20, spm_count = 0
Framing is CRC4, Line Code is HDB3, Clock Source is Internal.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (98 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Если счетчики Slip Secs и Errored Secs растут, значит источник синхронизации, скорее всего, указан неправильно. Об изменении источника синхронизации на настроенном шлюзе будет написано позже. Также потенциальной проблемой может быть неправильная настройка CRC4 (на одном конце CRC4 выключено, на другом - включено). Для отключения CRC4, выполните команду:

conf t
controller e1 0/0
framing no-crc4
exit
exit

После устранения проблем с соединением E1 проверьте сигналирование:

Global ISDN Switchtype = primary-net5
ISDN Serial0/0:15 interface
******* Network side configuration *******
dsl 0, interface ISDN Switchtype = primary-net5
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0xFFFF7FFF
Number of L2 Discards = 0, L2 Session ID = 132
Total Allocated ISDN CCBs = 0

Если значение State отлично от MULTIPLE_FRAME_ESTABLISHED, значит, скорее всего, неправильно указано сигналирование (обе стороны настроены как CPE или обе стороны настроены как NET). Для переключения шлюза обратно на CPE выполните:

conf t
interface Serial0/0:15
no isdn protocol-emulate network
exit
exit

Если вы используете удалённое подключение к консоли, не забудьте выполнить команду «terminal monitor» для вывода отладочных сообщений в консоль.

Для вывода в консоль сообщений ISDN выполните команду:

debug isdn q931

Для вывода в консоль сообщений SIP выполните команду:

debug ccsip messages

После завершения отладки нужно выключить вывод отладочных сообщений, т.к. это занимает ресурсы шлюза:

no debug isdn q931
no debug ccsip messages

Изменение источника синхронизации на настроенном шлюзе


Процедура довольно сложная, для изменения источника синхронизации придётся отключить все интерфейсы, имеющие отношение к E1 и удалить pri-group, полная последовательность команд:

conf t
voice-port 0/0:15
shutdown
interface Serial 0/0:15
shutdown
controller e1 0/0
shutdown
no pri-group timeslots 1-31

После этого можно поменять источник синхронизации (меняем на синхронизацию с линией):

no tdm clock E1 0/0
tdm clock E1 0/0 both export line

Теперь нужно вернуть все настройки обратно. Обратите внимание на то, что настройки интерфейса Serial 0/0:15 были сброшены на стандартные (если нужно сигналирование NET, нужно будет снова выполнить соответствующую настройку) и voice-port был удалён из всех dial-peer (нужно вернуть его обратно):

controller e1 0/0
no shutdown
pri-group timeslots 1-31
interface Serial 0/0:15
no shutdown
voice-port 0/0:15
no shutdown
dial-peer voice 20 pots
port 0/0:15
interface Serial0/0:15
isdn protocol-emulate network

шлюз e1, Cisco, asterisk, sip, настройка, шлюз, отладка, Подключение, VoIP, Channel, Logging, Time, call, Т38, внутренние номера